Changes to Modules on 22 April 2015

A number of changes are planned to modules on the system during the maintenance session on 22 April 2015.

If you have any questions or comments about the planned changes then please let the ARCHER Helpdesk know.

Change in default scientific software modules

The following module defaults will change:

castep      7.0.3 => 8.0.0 
nwchem      6.3 => 6.5

Change in default system software modules

The following module defaults will also change:

pmi                       5.0.5-1.0000.10300.134.8.ari=> 5.0.6-1.0000.10439.140.2.ari
cce                       8.3.3                       => 8.3.7
cray-mpich                7.0.3                       => 7.1.1
cray-shmem                7.0.3                       => 7.1.1
cray-ccdb                 1.0.3                       => 1.0.5
cray-petsc                3.5.1.0                     => 3.5.2.1
cray-petsc-complex        3.5.1.0                     => 3.5.2.1
cray-lgdb                 2.3.2                       => 2.4.0
cray-tpsl                 1.4.1                       => 1.4.3
cray-trilinos             11.8.1.0                    => 11.12.1.0
craype                    2.2.0                       => 2.2.1
craypkg-gen               1.2.0                       => 1.2.1
fftw                      3.3.4.0                     => 3.3.4.1
papi                      5.3.2                       => 5.3.2.1
perftools                 6.2.1                       => 6.2.2
perftools-lite            6.2.1                       => 6.2.2
gcc                       4.9.1                       => 4.9.2

Previewing the change

You can test the new system software module defaults ahead of the change with the command:

source $EPCC_PE_RELEASE/jan2015

This will set the default modules to the set specified above.

Note: scientific software module defaults are not changed using this mechanism and any changes need to be manually applied.

Reverting to current environment after the change

Once the change has been made, you can revert to the old defaults with the command:

source $EPCC_PE_RELEASE/sep2014

This will set the default modules to the old set specified above.

Note: scientific software module defaults are not changed using this mechanism and any changes need to be manually applied.