Planned Changes to Module Defaults: 11 June 2014

In order to provide users with the most up to date versions of software and available performance benefits we update the default versions of key software modules on a regular basis.

The next date planned for this update is 11 June 2014.

A full list of the planned changes is provided below. You can preview the changes and test your code with the new defaults by loading the update-preview/jun14 module on ARCHER:

module load update-preview/jun14

Note: this module will only swap the default versions of modules loaded by default for all users and may not work if you have modified your environment to change modules every time you log in. For modules not loaded by default or if you have changed your environment you will need to make the changes manually to preview the new defaults.

We will provide a counterpart module: old-defaults/jun14 that will switch your environment back to the previous defaults after the update has taken place. Please note, that there is no guarantee that older software will continue to be supported on ARCHER so these previous defaults may be removed in future. We strongly advise all users to use the latest versions of software when compiling and running their codes.

If you have any questions about the upgrade procedure, then please contact the ARCHER Helpdesk.

Throughout Wednesday 11 June 2014 the following module versions will be updated:

pmi/4.0.1-1.0000.9753.86.2.ari  =>    pmi/5.0.3-1.0000.9981.128.2.ari
atp/1.7.0                       =>    atp/1.7.2
cray-ga/5.1.0.2                 =>    cray-ga/5.1.0.4
cray-hdf5/1.8.11                =>    cray-hdf5/1.8.12
cray-hdf5-parallel/1.8.11       =>    cray-hdf5-parallel/1.8.12
cray-lgdb/2.2.2                 =>    cray-lgdb/2.3.0
cray-libsci/12.1.2              =>    cray-libsci/12.2.0
cray-mpich/6.1.1                =>    cray-mpich/6.3.1
cray-mpich2/6.1.1               =>    cray-mpich2/6.3.1
cray-netcdf/4.3.0               =>    cray-netcdf/4.3.1
cray-netcdf-hdf5parallel/4.3.0  =>    cray-netcdf-hdf5parallel/4.3.1
cray-parallel-netcdf/1.3.1.1    =>    cray-parallel-netcdf/1.4.0
cray-petsc/3.4.2.0              =>    cray-petsc/3.4.3.1
cray-petsc-complex/3.4.2.0      =>    cray-petsc-complex/3.4.3.1
cray-shmem/6.1.1                =>    cray-shmem/6.3.1
cray-tpsl/1.3.04                =>    cray-tpsl/1.4.0
cray-trilinos/11.4.1.0          =>    cray-trilinos/11.6.1.0
craype/2.01                     =>    craype/2.1.1
craypkg-gen/1.0.0               =>    craypkg-gen/1.1.1
papi/5.1.2                      =>    papi/5.3.0
perftools/6.1.2                 =>    perftools/6.1.4
perftools-lite/6.1.2            =>    perftools-lite/6.1.4
cce/8.2.1                       =>    cce/8.2.6
java/jdk1.7.0_07                =>    java/jdk1.7.0_45